Author Topic: JTS3Servermod - ServerGroupProtection Error  (Read 1418 times)

Eht0x

  • Newbie
  • *
  • Posts: 2
    • View Profile
JTS3Servermod - ServerGroupProtection Error
« on: October 03, 2017, 08:37:19 PM »
Wenn ich einen User zu einer ServerGruppe, die geschützt ist, hinzufügen möchte mit dem folgendem Befehl:

Code: [Select]
!FUNCTIONNAME add <server group id> <client unique id> [comment]

!servergroupprotection add <30> <fuJY1tIYGvDcp1ZL4p7rDNNL4DQ=>

bekomme ich folgende Fehlermeldung. 

Code: [Select]
Error while reading given client unique id!
Kann mir jemand sagen, an was dies liegen könnte? Der Bot zeigt in den Logs keine Fehlermeldungen an. 

Code: [Select]
2017-10-03 16:32:32 JTS3ServerMod INFO Got command from _Eht0x_: !reconnect
2017-10-03 16:32:32 JTS3ServerMod STATUS Virtual bot instance "bot1" restarts
2017-10-03 16:32:32 JTS3ServerMod INFO Unloaded all functions!
2017-10-03 16:32:32 JTS3ServerMod STATUS Virtual bot instance "bot1" starts now (build 6400)
2017-10-03 16:32:32 JTS3ServerMod STATUS Activate log level: INFO
2017-10-03 16:32:32 JTS3ServerMod INFO Successfully loaded function: ChannelNotify / channelnotify
2017-10-03 16:32:32 JTS3ServerMod INFO Successfully loaded function: RecordCheck / record
2017-10-03 16:32:32 JTS3ServerMod INFO Successfully loaded function: ServerGroupNotify / servergroupnotify
2017-10-03 16:32:32 JTS3ServerMod INFO Successfully loaded function: ServerGroupProtection / servergroupprotection
2017-10-03 16:32:32 JTS3ServerMod INFO Successful connected to localhost!
2017-10-03 16:32:32 JTS3ServerMod INFO Login as "serveradmin" successful!
2017-10-03 16:32:32 JTS3ServerMod INFO Successful selected virtual server on port 9987!
2017-10-03 16:32:33 JTS3ServerMod INFO Creating client database cache...
2017-10-03 16:32:33 JTS3ServerMod INFO Server connection log is activated and will be written into the file: /home/teamspeak/jts3/JTS3ServerMod_server1_login.csv
2017-10-03 16:32:33 Function channelnotify INFO Watching for new clients in channel "Support...[Wartezimmer]" (id: 92), sending message to all online clients of server group ids: 30, 52, 53, 54, 55
2017-10-03 16:32:33 Function record INFO Client get kicked from Server after start recording
2017-10-03 16:32:33 Function servergroupnotify INFO Watching for new connecting clients of selected server groups (id: 32), sending message to all online clients of server group ids: 30, 52, 53, 54, 55
2017-10-03 16:32:33 Function servergroupprotection INFO Server Group Protection will remove not allowed members from protected server groups (id: 30, 52, 53, 54, 55) but they will not kicked
2017-10-03 16:32:33 JTS3ServerMod INFO Bot started and connected successful, write !botinfo in server chat to get an answer!
2017-10-03 16:32:38 JTS3ServerMod INFO Client database cache created, 9 clients in cache.
2017-10-03 16:32:50 JTS3ServerMod INFO Got command from _Eht0x_: !servergroupprotection add <30> <UMM3lL7urxWd1JhQkH6R1WIPN1A=>
2017-10-03 16:33:02 JTS3ServerMod INFO Got command from _Eht0x_: !servergroupprotection add <30> UMM3lL7urxWd1JhQkH6R1WIPN1A=
2017-10-03 16:33:10 JTS3ServerMod INFO Got command from _Eht0x_: !servergroupprotection add <30> <UMM3lL7urxWd1JhQkH6R1WIPN1A>
2017-10-03 16:33:52 JTS3ServerMod INFO Got command from _Eht0x_: !servergroupprotection add < 30 > < fuJY1tIYGvDcp1ZL4p7rDNNL4DQ=  >
2017-10-03 16:48:23 Function servergroupprotection INFO Removed client "Venom" (db id: 30) from server group 53!
2017-10-03 18:08:26 JTS3ServerMod INFO Got command from _Eht0x_: !servergroupprotection add <30> <fuJY1tIYGvDcp1ZL4p7rDNNL4DQ=>
2017-10-03 18:13:37 JTS3ServerMod INFO Got command from _Eht0x_: !servergroupprotection add <30> <fuJY1tIYGvDcp1ZL4p7rDNNL4DQ=>

Stefan1200

  • Administrator
  • *****
  • Posts: 2095
    • View Profile
Re: JTS3Servermod - ServerGroupProtection Error
« Reply #1 on: October 03, 2017, 08:48:47 PM »
Die <> weg lassen.

Eht0x

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: JTS3Servermod - ServerGroupProtection Error
« Reply #2 on: October 03, 2017, 08:57:14 PM »
Wunderbar, es hat funktioniert. Am Anfang wollte er mir den Befehl aber nicht ausführen und hat ohne die Klammern garnicht geklappt. Der Bot hat sich kein Stück gerührt. Vielleicht habe ich mich ja vertippt :D

Vielen Dank ;)