Author Topic: Autostart auf Windowsserver  (Read 317 times)

HannesD

  • JTS3ServerMod Internal
  • *****
  • Posts: 7
    • View Profile
Autostart auf Windowsserver
« on: August 23, 2019, 04:46:40 PM »
Hallo,
Ich wollte jetzt mal die Autostartfunktion auf meinem WIN2008R2 Server zu erstellen.
Also; Doku aufgeschlagen, Gelesen, Gemacht.
  • Verknüpfung von JTS3_No_Window... erstellt
  • shell:startup, Verknüpfung reinkopiert
  • Neustart = Kein Autom. Start
  • Eigenschaften -> Als Admin starten
  • Neustart = Kein Autom. Start
  • Nochmal nach Doku gegangen, alle Einstellungen geprüft, immernoch kein Autostart
Also gut dachte ich mir, Machstes über Dienste.
Nach Doku gegangen, Folgende Fehlermeldungen bekommen, auch nach Neustart.
(Siehe Anhang)
Leider weis ich nichtmehr was ich jetzt noch Testen könnte.
MfG

Stefan1200

  • Administrator
  • *****
  • Posts: 2086
    • View Profile
Re: Autostart auf Windowsserver
« Reply #1 on: August 23, 2019, 05:01:29 PM »
Welche Java Version ist drauf? 32bit oder 64bit? Mit welchem CMD Skript den Dienst installiert?

HannesD

  • JTS3ServerMod Internal
  • *****
  • Posts: 7
    • View Profile
Re: Autostart auf Windowsserver
« Reply #2 on: August 23, 2019, 10:15:22 PM »
Hallo.
Java = 8.221 (Build 1.8.0_221-b11)  <== Gerade neu geupdatet!
Windows2008R2 64bit
Installiert mit dem Script aus dem JTS3Ordner

Der Bot läuft ja, wenn ich ihn manuell per Doppelklick Starte! (Hätte ich gleich mit hinschreibnen sollen; Sry  :-\ )
mfg

Stefan1200

  • Administrator
  • *****
  • Posts: 2086
    • View Profile
Re: Autostart auf Windowsserver
« Reply #3 on: August 23, 2019, 10:38:29 PM »
Ob Windows 64 oder 32 bit ist, ist nicht relevant. Hast du von Java die 32 oder 64 bit Version installiert?
Das du ein Skript aus dem JTS3 Ordner benutzt hast, ist mir schon klar...welches?

HannesD

  • JTS3ServerMod Internal
  • *****
  • Posts: 7
    • View Profile
Re: Autostart auf Windowsserver
« Reply #4 on: August 23, 2019, 11:31:58 PM »
... Umso Später der Abend ..... Entschuldigung vielmals....
Java ist, interresanter weise, das 32bit System Installiert.
Genutzt hatte ich das 64er Bit Script.

Damit ist ein Fehler eigentlich nun geklärt.

Da werd ich mal in nächster Zeit das 32bit Java, das warum auch immer drauf ist, gegen ein 64Bit ersetzen.

Zum Testen erstmal:

Starte ich das 32Bit Script, wurde der Dienst TS3Bot erfolgreich Installiert.
Nach Manuellen Starten des Dienstes im TaskM Startet der Bot und connectet sich.

Nach einem Neustart  Startet der Bot nicht automatisch.
In den Diensteigenschaften steht der Starttyp auf Automatisch.
Der Pfad zur prunsrv.exe stimmt auch

Anmelden tut er sich über das Lokale Systemkonto


Lieber erstmal Java auf die 64bit Version bringen?

Stefan1200

  • Administrator
  • *****
  • Posts: 2086
    • View Profile
Re: Autostart auf Windowsserver
« Reply #5 on: August 23, 2019, 11:40:12 PM »
Lieber erstmal Java auf die 64bit Version bringen?

Ein Test schadet sicher nicht.

HannesD

  • JTS3ServerMod Internal
  • *****
  • Posts: 7
    • View Profile
Re: Autostart auf Windowsserver
« Reply #6 on: August 27, 2019, 08:52:41 PM »
So.
JAVA ist auf Neuste version, Dienst installiert mit dem Script, Dienst ist auch über Taskmanager Startbar. Allerdings konnte ich die Autostartfunktion nochnicht ausgiebig testen. Momentan leider keine Zeit.
Ich Melde mich!

Mit freundlichen Grüßen