Recent Posts

Pages: [1] 2 3 ... 10
1
JTS3ServerMod Projects and Scripts from other people / Re: ServerQuery Error 1280
« Last post by Stefan1200 on February 18, 2022, 08:18:03 PM »
Me and a friend have checked logs high and low and come to  the conclusion that JTS3 and TS3 did nothing wrong.
The culprit was actually the MYSQL Server it self that for some reason restarted it self. And thus JTS3 made an error
in the log file.

Okay, so it really was an "database error" :)
2
JTS3ServerMod Projects and Scripts from other people / Re: ServerQuery Error 1280
« Last post by Gramse on February 18, 2022, 06:31:16 PM »
Ok some news in this matter.

Me and a friend have checked logs high and low and come to  the conclusion that JTS3 and TS3 did nothing wrong.
The culprit was actually the MYSQL Server it self that for some reason restarted it self. And thus JTS3 made an error
in the log file.

Thanks for the help and showed interest in the matter.
3
JTS3ServerMod Projects and Scripts from other people / Re: ServerQuery Error 1280
« Last post by Gramse on February 15, 2022, 04:27:47 PM »
Okay, this two lines are related together:
2022-02-13 16:26:34   JTS3ServerMod   ERROR   Error while getting server info!
2022-02-13 16:26:34   JTS3ServerMod   EXCEPTION   de.stefan1200.jts3serverquery.TS3ServerQueryException: ServerQuery Error 1280: database error

Every some minutes the JTS3ServerMod sends the command serverinfo to the TS3 server, if I remember correctly. And if that fails, the bot quits.
In fact, I have no idea, why the TS3 server answers with "database error" on that command. Maybe the TS3 server really has an database error? Maybe it helps if you check the TS3 server logs.

Ok thank you for the information, I will have to investigate further, I'll come back When I have checked the TS3 logs.
4
JTS3ServerMod Projects and Scripts from other people / Re: ServerQuery Error 1280
« Last post by Stefan1200 on February 14, 2022, 09:33:47 PM »
Okay, this two lines are related together:
2022-02-13 16:26:34   JTS3ServerMod   ERROR   Error while getting server info!
2022-02-13 16:26:34   JTS3ServerMod   EXCEPTION   de.stefan1200.jts3serverquery.TS3ServerQueryException: ServerQuery Error 1280: database error

Every some minutes the JTS3ServerMod sends the command serverinfo to the TS3 server, if I remember correctly. And if that fails, the bot quits.
In fact, I have no idea, why the TS3 server answers with "database error" on that command. Maybe the TS3 server really has an database error? Maybe it helps if you check the TS3 server logs.
5
JTS3ServerMod Projects and Scripts from other people / Re: ServerQuery Error 1280
« Last post by Gramse on February 14, 2022, 08:41:24 PM »
I guess the client Gramse used the chat command !botversion
Thats the reason for the first two lines. If course the id changes, because that is different with every connect to the TS3 server.
Maybe the HTTPS request is getting blocked by a firewall or something.

The EXCEPTION line "database error" is from the TS3 server. A server query command got the error message "database error" from the TS3 server. Maybe a full log would be more helpfull.

Thanks for the info I will look into it tomorrow, posting full JTS3ServerMod_server1.log in the mean time.

EDIT: This is an old bot that has been running sins 2016, and only been upgraded whenever upgrades been available, never made a clean install sins.
6
JTS3ServerMod Projects and Scripts from other people / Re: ServerQuery Error 1280
« Last post by Stefan1200 on February 14, 2022, 06:58:41 PM »
I guess the client Gramse used the chat command !botversion
Thats the reason for the first two lines. If course the id changes, because that is different with every connect to the TS3 server.
Maybe the HTTPS request is getting blocked by a firewall or something.

The EXCEPTION line "database error" is from the TS3 server. A server query command got the error message "database error" from the TS3 server. Maybe a full log would be more helpfull.
7
JTS3ServerMod Projects and Scripts from other people / ServerQuery Error 1280
« Last post by Gramse on February 14, 2022, 04:34:07 PM »
Hello everyone!

I have a question about the error code in the subject. complete line from log below.

cut from JTS3ServerMod_server1.log

2022-02-13 16:24:45 JTS3ServerMod   ERROR   Unable to request the current JTS3ServerMod version from https://www.stefan1200.de for the client Gramse (id: *******)!
2022-02-13 16:26:34 JTS3ServerMod   ERROR   Error while getting server info!
2022-02-13 16:26:34 JTS3ServerMod   EXCEPTION   de.stefan1200.jts3serverquery.TS3ServerQueryException: ServerQuery Error 1280: database error

Now to my question is this a problem on www.stefan1200.de or is it a local problem with my database?
I'm a bit confused on were to start looking.

Any suggestions or ideas are welcome.

And to make it worse the ID:***** are different every time it appears in the log.

Thanks in advance.
8
Re-release of the version 6.5.7 (31.01.2020)
But all 3rd party libraries was updated. Especially all SSH users should update!

Check first post for the changes (Changelog).
9
Erneute Veröffentlichung der Version 6.5.7 (31.01.2020)
Aber alle 3rd Party Bibliotheken wurden aktualisiert. Insbesondere SSH Nutzer sollten aktualisieren.

Lese den ersten Beitrag für die Änderungen (Entwicklungsgeschichte).
10
Aufgrund der zahlreichen Anfragen:
Meine Anwendungen sind von der Log4J Sicherheitslücke, auch bekannt unter der Nummer CVE-2021-44228, nicht betroffen. Ich setze kein Log4J ein, gar keine Version davon.
Pages: [1] 2 3 ... 10