Author Topic: php7 abgekündigt - Kommt php8 Unterstützung  (Read 1370 times)

supertoasty

  • JTS3ServerMod Internal
  • *****
  • Posts: 2
    • View Profile
php7 abgekündigt - Kommt php8 Unterstützung
« on: September 15, 2023, 07:01:54 PM »
Hallo zusammen,

wie bereits bekannt ist ist php7 abgekündigt und soll vermutlich nicht mehr weiter entwickelt werden.
Da im Webinterface die Datenbankverbindungen mit mysqli (welches in php8 nicht mehr unterstützt wird) durchgeführt werden, wollte ich mal fragen, ob bald auch php8 vom Webinterface unterstütz wird?

Liebe Grüße

supertoasty

Stefan1200

  • Administrator
  • *****
  • Posts: 2244
    • View Profile
Re: php7 abgekündigt - Kommt php8 Unterstützung
« Reply #1 on: September 15, 2023, 07:48:39 PM »
Es ist weiterhin möglich mysqli mit PHP 8.1 und 8.2 zu verwenden, man muss ggf. ein Modul installieren und es aktivieren.
Ich habe nicht die Zeit den kompletten Datenbank Part im Web Interface neu zu machen, da das Wechseln von mysqli zu PDO nicht ist, was ich in wenigen Minuten machen kann.

It is still possible to use mysqli with PHP 8.1 and 8.2, you might have to install a module and have to enable it again.
I don't have the time to recreate the whole database part of the web interface, because switching from mysqli to PDO is nothing which I can do within some minutes.
« Last Edit: September 15, 2023, 07:50:14 PM by Stefan1200 »