Author Topic: Found plugin api build 0, but need api build 4. error  (Read 161 times)

finary1994

  • Newbie
  • *
  • Posts: 2
    • View Profile
Found plugin api build 0, but need api build 4. error
« on: November 03, 2017, 06:56:08 PM »
Hey Community,

Ich bin irgendwann auf eine Idee für ein Plugin für JTS3ServerMod gekommen, das ich privat realisieren wollte.
Habe mir die API-Docs angesehen und gedacht das lässt sich bestimmt leicht umsetzen.
Bin aber noch relativ unerfahren was den Umgang mit Eclipse & Java angeht.
Da Ich aber Erfahrungen mit anderen Programmiersprachen gemacht habe (C++, C# & autoit),
habe ich mir gedacht sooo schwer kann das nicht sein. (Das Prinzip lässt sich doch eig immer übertragen & wenn nicht, Google hilt)

Zum Anfang wollte Ich das kleine Tutorial machen was dann in der Console eine msg ausgibt.
Und ab denn Punkt taucht mein erstes Problem auf:

bot: Virtual bot instance "testpl" starts now (build 6402)
bot: Plugin "testpl.jar" is not compatible with this JTS3ServerMod version. Found plugin api build 0, but need api build 4 - Plugin unloaded!

Info:
Ein lokaler TS Server & jts3ServerMod auf Windows benutze ich zum debuggen (Keine lust das immer auf Debian hochzuladen :D )

Meine Frage:
Was habe ich falsch gemacht und wie kann man das korrigieren? Ich habe bestimmt einen dummen Anfänger Fehler gemacht.

MFG,
Tim


finary1994

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Found plugin api build 0, but need api build 4. error
« Reply #2 on: November 03, 2017, 08:06:39 PM »
Danke funktioniert jetzt.